Unexpected service interruption from Amazon
Incident Report for Dropified
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 19:16 UTC
Update
Dropified is back online now, but some features are not working yet (like Products Feed, Uploading images...)
Posted Mar 31, 2020 - 14:42 UTC
Identified
Expected to be back online within the hour.
Will update with new details as they arrive
Posted Mar 31, 2020 - 14:21 UTC
This incident affected: Dropified.