Shopify Slow page loading on some stores
Incident Report for Dropified
Resolved
This incident has been resolved.
Posted Jun 20, 2018 - 21:02 UTC
Identified
Shopify is experiencing an interruption in service which affect Dropified:
https://status.shopify.com/incidents/qxqvmkyh80b1
Posted Jun 20, 2018 - 18:05 UTC
This incident affected: Shopify API Reliance.