Aliexpress "Could not select Other Payment Method" Error
Incident Report for Dropified
Resolved
This incident has been resolved.
Posted Jun 21, 2018 - 16:45 UTC
Monitoring
An AliExpress issue has caused the extension to show a "Could not select Other Payment Methods" error.
We've added a workaround for this issue in version 2.14.0 of the extension.

Please note that this is an AliExpress issue, we’ve noticed that sometimes AliExpress shows malformed JavaScript which stops the entire page from loading successfully. The issue is inconsistent and may happen even without using the Dropified extension.

Our workaround simply reloads the page until AliExpress loads correctly.

How To Update The Extension To The Latest Version:
https://app.dropified.com/pages/how-to-update-the-extension-to-the-latest-version
Posted Jun 21, 2018 - 11:16 UTC
This incident affected: AliExpress Order Fulfillment.